2008年01月13日

[XSIスクリプト] VC++2005 ExpressEdition でプラグイン作るときの覚書

ExtrudeByCurveをC++で書き直そうと思ったんだけど、ビルドで躓いたので忘れないようにメモ。

・bufferoverflowU.libが見つからないというエラーが出てビルド出来ない。

「Microsoft Platform SDK」が必要。 ExpressEditionには含まれていないので別途インストールする必要がある。
http://www.microsoft.com/japan/msdn/vstudio/express/visualc/usingpsdk/

・対象コンピュータの種類 'x64' と競合していますというエラーが出てビルド出来ない。

.vcprojファイルを開いて
AdditionalOptions="/MACHINE:AMD64" を
AdditionalOptions="/MACHINE:I386" に書き換えたらビルドできた。
http://ml.tietew.jp/cppll/cppll_novice/thread_articles/1275

テスト用のプラグインのビルドが通ったら満足しちゃって、C++に移植とかもうどうでもよくなってきちゃったよ。

この記事へのコメント
コメントを書く
お名前:

メールアドレス:

ホームページアドレス:

コメント:


この記事へのトラックバック
×

この広告は1年以上新しい記事の投稿がないブログに表示されております。